Page tree
Skip to end of metadata
Go to start of metadata

中文标题【支持的平台】

这个平台描述了 Confluence 支持的平台列表。请在安装 Confluence 之前阅读本页面的内容。这个页面的信息是针对 Confluence 版本 Confluence 6.15 的。

更多信息请参考:

  • 当使用 Confluence 的时候结束支持的一些平台和浏览器: End of Support Announcements for Confluence

  • 有关 Confluence 支持的平台和硬件需求: 系统需求
  • Go to  > 基本配置(General Configuration) > Support Tools to check your instance health. It looks at things like your licence validity, Tomcat version, basic database setup and more. 


定义:

(tick) 支持的(Supported) - 你可以在 Confluence 6.15 这个平台上使用。

(info) 限制的(Limited) - 你可以在这个平台上对 Confluence 进行评估,但是不建议你再 Confluence 生产环境中使用。

(warning) 已丢弃(Deprecated) - 对这个平台的支持将会在后序版本中被废弃。


浏览器


桌面浏览器:

(tick) Internet Explorer 11

(tick) Microsoft Edge

(tick) Chrome

(tick) Firefox

(tick) Safari (Mac only)

移动浏览器:

(tick) Chrome

(tick) Firefox

(tick) Safari (iOS only)

(tick) Android 4.4 (KitKat) or later

移动操作系统:
(需要移动 app 的支持)

(tick) iOS 11 or later

(tick) Android 4.4 (KitKat) or later

你需要了解:

  • We test Confluence in Internet Explorer 11 using standards-compliant rendering mode, not compatibility mode. You may experience problems in compatibility mode. 
  • The Confluence setup wizard requires Javascript to be enabled while installing Confluence. Learn more
  • Parts of Confluence won't display correctly if your browser window size is less than 1024x768. 

Key(tick) = Supported. (error) = Not Supported

Java 环境 (Java version)


Oracle JRE / JDK

(tick) 1.8

(warning) 针对 1.8.0_25 和 1.8.0_31  有一些 已知问题,针对 Java 1.8.0_45 还会有 其他已知问题。Confluence 的官方不建议使用上面的 JDK 版本运行 Confluence。

Confluence 服务器支持的操作系统平台


Microsoft Windows (including 64-bit)(1)

(tick) (Microsoft Supported Versions only)

Linux / Solaris (1,2)

(tick)

Apple Mac OS X

(error) 不支持作为服务器. (tick) 做为客户端能被支持

应用服务器(Application servers)


Apache Tomcat

(tick) 8.0.x 12

数据库


PostgreSQL

(tick) 9.2, 9.3

MySQL (3)

(tick) 5.5, 5.6 (5.6.16 和后续版本都能够被支持 - 更多信息)

(error) MariaDB 和 Percona 服务器都不能够不被支持。

(warning) 针对 MySQL 5.5 系统将会由下面的已知问题: CONF-37829 - Getting issue details... STATUS

Oracle

(tick) 12c

Microsoft SQL Server

(tick) 2012, 2014

HSQLDB (4)

(tick) (这个是嵌入使用的数据库仅用于评估 Confluence 时使用)

网页浏览器 - 桌面环境


Microsoft Internet Explorer (Windows) (5,6)

(tick) 10, 11

Mozilla Firefox (所有平台)

(tick) 最新的稳定版都能被支持

Google Chrome (Windows 和 Mac) (7)

(tick) 最新的稳定版都能被支持

Safari (Mac) 

(tick) 最新的稳定版都能被支持

网页浏览器 - 移动终端


Mobile Safari (iOS) (8)

(tick) 最新的稳定版都能被支持

Android (Android) (9)

(tick) Android 4.0.3 (Ice Cream Sandwich) 使用的默认浏览器

Chrome (Android and iOS) (8,9)(tick) 最新的稳定版都能被支持
  1. Confluence 是一个纯 Java 应用。Confluence 应该在安装有 JRE 或者 JDK 的平台上运行。
  2. 一些用户可能会在 基于SPARC (SPARC,全称为“可扩充处理器架构”(Scalable Processor ARChitecture),是RISC微处理器架构之一)的硬件上使用 Confluence,Atlassian 官方仅支持 Confluence 在 x86 硬件平台和 64 位的 x86 平台上运行。
  3. 请确定你的 MySQL 数据库使用 InnoDB 存储引擎,如果你使用 MyISAM 存储引擎将会导致数据错误。
  4. Confluence 默认使用的是 HSQL 数据库,这个数据库仅用于在评估 Confluence 的时候使用,因为当系统崩溃的时候,如果你使用 HSQL 数据库将会导致数据丢失。在实际的生产环境中,我们强烈建议使用外部数据库来作为 Confluence 实例的数据库。
  5. Internet Explorer 8 和 9 不只是 HTML5 的拖放功能。Confluence 的拖放功能是需要 HTML 5 的支持的,所以 Internet Explorer 8 和 9 将没有办法使用这个功能。同时 Internet Explorer 10 的桌面模式是支持拖放功能的。如果你希望在 Internet Explorer 10 中使用 Confluence 提供的拖放功能,那么你需要将你的 Internet Explorer 10 使用桌面模式('desktop' mode)。Internet Explorer 10 中的 现代模式('modern' mode)不支持拖放。
  6. Confluence is tested with these versions of Internet Explorer in standards-compliant rendering mode, not compatibility mode. Enabling compatibility mode may cause problems because it emulates older, unsupported rendering modes.
  7. Chrome 没有 WEBDAV / 插件支持,所以 Editing an Office Document from Confluence 这个功能是不能在 Chrome 中使用的,请参考 CONF-23322 来获得这个问题的最新进展。
  8. Confluence 不支持在 iOS 移动设备上的 移动 Safari 浏览器(例如在 iPhone 和 iPad 上使用)。请参考 CONF-19523 来获得这个问题的最新进展。
  9. Confluence 不支持在 Android 设备上进行编辑。
  10. 基于 Lucene 的技术需求 NFS 磁盘挂载在 Linux 操作系统上不能够被支持。
  11. 我们当前并不支持 MariaDB 或 Percona 服务器。请参考  CONF-36471 - Getting issue details... STATUS  和  CONF-29060 - Getting issue details... STATUS  来获得更多信息。
  12. 我们仅支持集成到 Confluence 中的 Tomcat 版本。
  13. 你需要在你安装 Confluence 的时候启用 Javascript。将你的浏览器安全级别设置为高,并且禁用 Javascript 的话,将会阻止你进一步按照 Confluence。请参考 这个知识库 来获得更多有效信息。
  • No labels

1 Comment

  1. 虽然官方的文档说不能给支持 MariaDB 数据库,但是我们现在的程序就是运行在 MariaDB 数据库上的。

    也没有发现有什么太大的问题。一般来说,我们不觉得会出现什么重大的功能缺陷。