Page tree
Skip to end of metadata
Go to start of metadata

中文标题【数据库 JDBC 驱动】

本页面提供了支持的数据库的所有 JDBC 驱动下载链接。

基于许可证的原因,我们没有将 MySQL 或 Oracle 的数据库驱动整合到 Confluence 中,因此你需要在 Confluence 启动之前手动下载和安装驱动。

如果你使用的是 PostgreSQL 或 Microsoft SQL Server,数据库驱动已经整合到 Confluence 中了所以你不需要重新下载和安装驱动。

添加你数据库驱动(MySQL 和 Oracle)

如果 Confluence 不能找到正确的数据库驱动的话,Confluence 配置向导将会在数据库配置步骤中停止进行。

希望你的数据库驱动能够在 Confluence 中使用:

  1. 停止 Confluence
  2. 下载和解压下面列表中需要的数据库驱动。
  3. 解压 .jar 文件到你的 <installation-directory>/confluence/WEB-INF/lib 目录中。
  4. 重新启动 Confluence,然后通过你的浏览器访问 http://localhost:<port> 来进入安装过程。

安装向导将会返回到数据库配置界面中,让你从这里开始下一步的数据库配置。

支持的驱动


本页中的内容:


相关页面:

数据库

驱动已捆绑?

JDBC 驱动

备注更多信息

PostgreSQL

(tick)

9.4-1202 JDBC 41 driver download



我们推荐你使用 JDBC 4 的驱动。

如果你希望使用更新的驱动版本,你可以从 PostgreSQL website 上下载。JDBC 41 驱动只能在 1.8 JVM 上工作。

Database Setup for PostgreSQL

Microsoft SQL Server

(tick)Microsoft JDBC Driver for SQL Server download 

我们推荐你使用整合的 Type 4 JDBC 驱动。

如果你希望使用更新的驱动版本,我们可能不能因为你 JDBC 驱动产生的问题提供技术支持。

Database setup for Microsoft SQL Server

(tick)

jTDS 1.3.1 driver download


(warning) 这个驱动已经过时了,新的 Confluence 安装将会使用 Microsoft JDBC Driver for SQL Server(上面提到的)。

如果你已经升级已经存在的 Confluence 站点到 Confluence 6.4。你应该继续使用捆绑安装的 jTDS 驱动。我们将会在后续的更新版本中进行整合。

MySQL

(error)

Connector\J 5.1 driver download


基于许可证问题的考虑,MySQL 驱动没有捆绑到 Confluence 中。

Confluence 当前是基于 5.1.42 驱动进行测试的。

最新的 (8.x)驱动还不能够被支持。

Database setup for MySQL

Oracle

(error)

JDBC driver downloads

基于许可证问题的考虑,Oracle 驱动没有捆绑到 Confluence 中。

针对 Oracle 12c 使用 12.2.0.x 驱动(ojdbc8.jar)

我们推荐你只使用 thin 驱动。请参考 Oracle JDBC driver FAQ 页面中的内容。

Database setup for Oracle


如果你希望使用不支持的或者自定义 JDBC 驱动(或者从一个不支持的或者你的自定义 JINDI 数据源连接 driverClassName )collaborative 编辑可能不能使用。你必须使用支持的驱动。


  • No labels