Skip to end of metadata
Go to start of metadata

中文标题【系统需求】

Confluence 可以多个操作系统和数据库平台上运行,同时也能运行在多种物理或者虚拟服务器上。

请参考 Supported Platforms 页面来找到 Confluence 可以运行的平台版本列表或者访问 Supported Platforms FAQ 来获得官方支持处理的程序。

软件需求

操作系统

Atlassian 支持的操作系统列表可以在 Supported Platforms 页面上访问到。

如果你希望运行 Confluence 在虚拟硬件上,请首先阅读 Running Confluence in a Virtualized Environment 页面中的内容。

本页中的内容:

应用服务器

我们只支持 Confluence 运行在绑定分发包中的 Apache Tomcat。

数据库

你将需要一个外部数据库服务器来运行 Confluence。请参考 Supported Platforms 页面中的内容来获得 Confluence 支持的数据库列表。

当你对 Confluence 进行评估的时候,你可以使用嵌入的 H2 数据库。但是,如果你希望在你的开发小组中使用 Confluence 的时候,你需要使用外部的数据库而不要使用嵌入的 H2 数据库。

Java

Java Runtime Environment (JRE) 也被打包了,当你在Windows 或者 Linux 安装程序进行安装的时候将会被使用。你不需要自行安装 Java。

当你选择从归档文件中安装 Confluence 的话,你需要选择支持的 JRE 或 JDK,同时你的 JAVA_HOME 变量也要被设置正确。请参考, Installing Java for Confluence 页面中的内容来获得更多的信息。

防病毒考虑

在 Confluence 环境下安装的防病毒软件将会显著的降低 Confluence 的性能。防病毒软件将会干扰 Confluence 对磁盘的访问而可能会导致 Confluence 出现错误。这个问题在你将 Confluence 运行在 Windows 平台下的时候尤其明显。无论你的硬件配置有多么强大,防病毒软件总是能够对 Confluence 的性能带来负面影响。

你应该考虑在你的防病毒软件中进行配置忽略下面的目录扫描:

  • Confluence home 目录
  • Confluence 的索引目录(index)
  • 所有数据库相关的目录

硬件需求

请避免运行 Confluence 在 SPARC-based 硬件上,Atlassian 官方只对运行在  x86 硬件和 64-bit 的 x86 硬件提供支持。

请参考 Server Hardware Requirements Guide 来获得更多的信息。

你也可以考虑查看下面的一些小技巧: 减少内存溢出错误 ,在 Permanent Generation Size 页面中的内容。

托管方案 – Confluence Cloud

如果你没有在本地安装 Confluence 的资源的话,你可以考虑使用 Confluence Cloud 服务。Atlassian 能够为你运行和维护你的 Confluence 安装实例,处理所有的测试,监控和升级程序。

  • No labels